Does 4.9 no longer support sql? Or 4.9 simply added postgresql support?

Does 4.9 no longer support sql? Or 4.9 simply added postgresql support? what originally supported are remain supported.

we have our current production database in sql server. If we want to upgrade to corda 4.9 community version, we need to migrate to Postgresql , right? or is there any other option?

PostgreSQL is the only supported version for Corda 4.9. Previously, up until version 4.6 there were untested community feature on SQL support.

yes you will have to migrate to Postgresql. Corda enterprise supports Oracle, sql server and postgresql.